 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 3:48 AM |
|
|
|
|
|
| Seagull |
| Posts |
111 |
| Word Cnt. |
6,112 |
| BDay |
May 8 |
| Sign |
Taurus |
| Sex |
 |
|
|
|
Joined: Apr 01, 2007
Local time: 5:26 AM
|

|
|
|
|
 |
Ok when i log in to ezmod i go to page that shows unprocessed mods if i click process i get just grey page on right side of acp if i click process with preview checked i get a list of all the files its going to edit when i click view on any of the files listed to be edited it i get page cant be displayed http://www.yahoo-attitude.com/pspexpressions/admin/admin_easymod.php? and also has name of mod and pw to login to exmod and bunch of numbers, I have no idea where my processed mods and backup folder went Im wondering if at this point since there gone should i reinatall ezmod again ?  |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 4:06 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 5:26 AM
Location: St Pete, FL
|

|
|
|
|
 |
Yes, why don't you do that. Go ahead and reinstall EM and see if that corrects the problem. Before you can reinstall EM, you will have to decrease the EM Version number in your phpbb_config table. Here are three ways to accomplish that...
EM Version Change
If you have had EM installed before, you need to decrease the EM version number before you can reinstall it. The EM Version number is stored in your phpbb_config table. Here are 3 different ways to decrease EM's Version number...
EM Version Change
Before you can reinstall EM, you need to decrease the EM version number in your phpbb_config table...
- EM Version Change Option 1
I created this DB Update file that you can run from your browser. Download and unzip the following file, then upload it to your phpBB root and run it from your browser:
em_db_decrease_version.zip
The path to the unzipped file might look something like this in your browser:http://yourdomain.com/forum/em_db_decrease_version.php
- EM Version Change Option 2
If you already had EM 0.3.0 installed, then you will need to change the EM Version back so that the install will think that this is an Upgrade. You can use this tool to change your EM Version so that you can reinstall EM on your board:
EM_Version_Changer
Once the EM Version Changer is installed, set the EM version to 0.1.13 or 0.2.0...
- EM Version Change (Manual Option 3)
If you want to manually change the EM version, you can do so in your phpbb_config table. Just look for the record beginning with EM_version. Then you can change the related field to 0.1.13. You could also delete all the records in the phpbb_config table that begin with EM_ and delete the phpbb_easymod table too to have the new install recreate everything...
phpMyAdmin - Manually Changing the EM Version Number
The following is how you manually modify your EM password using phpMyAdmin. You can get into your database through your CPanel by clicking on phpMyAdmin. Follow the following instructions:
I'm sure that every host is different. I will tell you how I run my queries manually and hopefully it will be close to what you have available to you. The following may or may not be similar to what you have...
Log into your domain Control Panel and find the database icons. You should be able to find the phpMyAdmin icon. Click on it...
Hopefully that will log you into your phpAdmin panel. You may need to provide a username and password...
In the phpMyAdmin panel, click on the Databases hyperlink...
Hopefully that should take you where you can select your database. You may only have one. Select your database hyperlink...
That should open up the display of all the tables in your database. Ignore them. Somewhere on the page, you should see something similar to this:
Click on the phpbb_config table in the Left column navigation bar:
Then on the top left of the right window, click on the Browse button:
Then to display all the records, change the row settings to 500 starting with record 0, then press the Show button:
Scroll down to the EM version field, then click on the little pencil icon next to the record to edit it:
Enter the following into the config_value Value editbox. Any version less than your current version will work...
Then press the Go button. You should now be able to reinstall EM...
If you are still unclear on how to do this, send me a PM and I can probably reset your EM version for you...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 4:27 AM |
|
|
|
|
|
| Seagull |
| Posts |
111 |
| Word Cnt. |
6,112 |
| BDay |
May 8 |
| Sign |
Taurus |
| Sex |
 |
|
|
|
Joined: Apr 01, 2007
Local time: 5:26 AM
|

|
|
|
|
 |
| I downloaded the file in option one and ran it page said done (1 queries). so now just reinstall ezmod ? |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 4:51 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 5:26 AM
Location: St Pete, FL
|

|
|
|
|
 |
Yes, it should be good to go now. All that did is decrease the EM Version in your phpbb_config table, so that EM doesn't complain. I think it is silly to have that code in EM to begin with. People should be able to reinstall the same version as many times as they want without having to jump through hoops to do it...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 5:47 AM |
|
|
|
|
|
| Seagull |
| Posts |
111 |
| Word Cnt. |
6,112 |
| BDay |
May 8 |
| Sign |
Taurus |
| Sex |
 |
|
|
|
Joined: Apr 01, 2007
Local time: 5:26 AM
|

|
|
|
|
 |
I've reinstalled ezmod successfully and went logged in and clicked process and it went to page like supposed to showing what it did and didnt do and now i have the following error Critical Error
FIND FAILED: In file [includes/usercp_register.php] could not find:
$signature = str_replace('
MOD script line #291 :: FAQ :: Report
I want to say I remember reading somewhere that this section of code has changed slightly , yea i found it its now listed as $signature = (isset($signature)) ? str_replace(' ', "\n", $signature) : ''; and the code for the mod goes before it however i have no clue what to do with it since ezmod doesnt find it |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 6:00 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 5:26 AM
Location: St Pete, FL
|

|
|
|
|
 |
Ok, before you go any further, you should update your database so that when the MOD is installed, your forum will not go down. This is in the author's Readme_first.txt file:
| Quote:
|
|
2. Place the included title_install.php into your root phpBB directory, and then run it. This will make the necessary database alterations. When it has completed, make sure it didn't report any errors, and then delete the file.
|
So upload the title_install.php to your phpBB forum folder, then run it from your browser. The path could look something like this:
| Code:
|
|
http://yourdomain.com/phpBB2/title_install.php
|
Once you have successfully made the database modifications, you can delete the title_install.php file from your phpBB forum folder...
Then to correct the MOD script, do this:
OPEN
custom_title/manual_install.txt
FIND
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
$signature = str_replace('
|
REPLACE WITH
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
$signature = (isset
|
Save, upload, and try again using EM...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 6:25 AM |
|
|
|
|
|
| Seagull |
| Posts |
111 |
| Word Cnt. |
6,112 |
| BDay |
May 8 |
| Sign |
Taurus |
| Sex |
 |
|
|
|
Joined: Apr 01, 2007
Local time: 5:26 AM
|

|
|
|
|
 |
I'm so glad you have paitence , I have 2 styles on my board other than subSilver which is why I usually do manull installs if i had your knowledge im sure wouldnt be a problem with ezmod anyways i did what you said and that went fine now i have these errors
Warning
| Code:
|
FIND FAILED: In file [templates/Acid/admin/board_config_body.tpl] could not find:
<td class="row2"><input type="radio" name="prune_enable
</tr>
MOD script line #543 :: FAQ :: Report
Critical Error
FIND FAILED: In file [templates/subSilver/profile_add_body.tpl] could not find:
<input type="text" class="post"style="width: 200px" name="interests" size="35" maxlength="150" value="{INTERESTS}" />
</td>
</tr>
|
Heres Original subsilver profile_add_body.tpl line
| Code:
|
|
<input type="text" class="post" style="width: 200px" name="interests" size="35" maxlength="150" value="{INTERESTS}" />
|
its exactly the same as what ezmod says cant find
and heres what the line in the other styles admin/board_config_body.tpl looks like
| Code:
|
<td class="row1">{L_ENABLE_PRUNE}</td>
<td class="row2"><input type="radio" name="prune_enable" value="1" {PRUNE_YES} /> {L_YES} <input type="radio" name="prune_enable" value="0" {PRUNE_NO} /> {L_NO}</td>
|
|
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 7:14 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 5:26 AM
Location: St Pete, FL
|

|
|
|
|
 |
All it takes is one extra character to make it so that the MOD script doesn't match, including spaces and tabs. So with EM, less is best. You can usually cut the code down to a unique word or phrase to get it to work. The more text you have in the FIND, the more likely that there will be a difference/conflict...
Ok, try this:
OPEN
custom_title/manual_install.txt
FIND
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
<td class="row2"><input type="radio" name="prune_enable
</tr>
|
REPLACE WITH
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
prune_enable
</tr>
|
FIND
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
<input type="text" class="post"style="width: 200px" name="interests" size="35" maxlength="150" value="{INTERESTS}" />
</td>
</tr>
|
REPLACE WITH
| Code:
|
#
#-----[ FIND ]------------------------------------------
#
{INTERESTS}
</td>
</tr>
|
Save, upload, and try again using EM...
If you don't understand why my suggestion above will work, please ask. Once you understand the basics of how to get these MODs to install cleanly, you should be able to install even the most difficult MODs using EM...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 7:19 AM |
|
|
|
|
|
| Seagull |
| Posts |
111 |
| Word Cnt. |
6,112 |
| BDay |
May 8 |
| Sign |
Taurus |
| Sex |
 |
|
|
|
Joined: Apr 01, 2007
Local time: 5:26 AM
|

|
|
|
|
 |
| No actually I was just thinking I'm starting to understand it now that I see what your doing , I'm going to try these last edits now and see what happens , then try correcting any other errors myself first b4 bugging you with it |
|
|
 |
 |
| Back to Top |
|
|
 | Re: Axedon Title Mod |  |
Posted: 04/02/2007 7:22 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 5:26 AM
Location: St Pete, FL
|

|
|
|
|
 |
Ok, good luck. Just don't simplify it too much or you might end up placing the code in the wrong place if the FIND can match many places in the phpBB file...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Information |  |
|