 | [Solved] External Forum Redirect MOD |  |
Posted: 06/03/2007 1:23 AM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
I have tried to install External Forum Redirect MOD (http://4fxearth.net/phpBB2/downloads/phpBB/MODs/Admin/External_Forum_ Redirect.zip) and it came up with
Error Detail
Critical Error
FIND FAILED: In file [admin/admin_forums.php] could not find:
// There is no problem having duplicate forum names so we won't check for it.
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id,
any ideas? |
|
|
 |
 |
| Back to Top |
|
|
 | Re: External Forum Redirect MOD |  |
Posted: 06/03/2007 5:32 PM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 11:20 PM
Location: St Pete, FL
|

|
|
|
|
 |
Yes, the Simple Subforums MOD added code here that separated the comment from the code, so that's why the FIND didn't work. The MOD author shouldn't have included the comment in the FIND command...
Ok, try this:
OPEN
External Forum Redirect/Install.txt
FIND
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
# There is more to this piece of code than what is
# shown here. This excerpt is shown since many hacks
# alter this code, and so yours may be different than
# the default code. This portion should remain constant.
#
// There is no problem having duplicate forum names so we won't check for it.
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id,
|
REPLACE WITH
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id,
|
Save, upload, and try again using EM...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: [Solved] External Forum Redirect MOD |  |
Posted: 06/03/2007 10:25 PM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
Thank, followed your instructions and tried to install again and it cam up with:
Critical Error
Function Trace: open_files[5]->modio_open[1]
Could not open [\admin\admin_forums.php] for reading.
MOD script line #187 :: FAQ :: Report
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: External Forum Redirect MOD |  |
Posted: 06/04/2007 2:32 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 11:20 PM
Location: St Pete, FL
|

|
|
|
|
 |
Yes, the MOD author made a silly mistake here. In fact, there were far too many mistakes for me to explain here in my message, so I went ahead and cleaned up the MOD script and created this EM Friendly version. Try this and see how it goes. Let me know if you encounter any problems with this...
External Forum Redirect - EM Friendly
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: [Solved] External Forum Redirect MOD |  |
Posted: 06/04/2007 2:37 AM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
Uploading now, Ill tell ya how it goes  |
|
|
 |
 |
| Back to Top |
|
|
 | Re: [Solved] External Forum Redirect MOD |  |
Posted: 06/04/2007 2:38 AM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
*Sigh*
Error Detail
Critical Error
IN-LINE FIND FAILED: In file [admin/admin_forums.php] could not find:
" . intval($HTTP_POST_VARS['forumstatus']) . "
MOD script line #256 :: FAQ :: Report |
|
|
 |
 |
| Back to Top |
|
|
 | Re: External Forum Redirect MOD |  |
Posted: 06/04/2007 2:50 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 11:20 PM
Location: St Pete, FL
|

|
|
|
|
 |
Nope, I'm not surprised. This and another FIND should be multi-line FINDs instead of what is there now. So this is how you fix it:
OPEN
External_Forum_Redirect/Install_em_friendly.txt
FIND
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id,
|
REPLACE WITH
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id,
VALUES
|
FIND
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
# There is more to this piece of code than what is
# shown here. This excerpt is shown since many hacks
# alter this code, and so yours may be different than
# the default code. This portion should remain constant.
#
$sql = "UPDATE " . FORUMS_TABLE . "
|
REPLACE WITH
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
$sql = "UPDATE " . FORUMS_TABLE . "
SET
|
Save, upload, and try again using EM...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: [Solved] External Forum Redirect MOD |  |
Posted: 06/04/2007 3:01 AM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
Installed good but look at the forum  |
|
|
 |
 |
| Back to Top |
|
|
 | Re: External Forum Redirect MOD |  |
Posted: 06/04/2007 3:49 AM |
|
|
|
|
|
| Site Admin |
| Posts |
30757 |
| Word Cnt. |
2,628,690 |
| BDay |
Jul 28 |
| Sign |
Leo |
| Sex |
 |
|
|
|
Joined: Sep 25, 2004
Local time: 11:20 PM
Location: St Pete, FL
|

|
|
|
|
 |
Yep, that's another mistake. Go ahead and Restore the EM Backups, then do this:
OPEN
External_Forum_Redirect/Install_em_friendly.txt
FIND
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">
#
#----------[ REPLACE WITH ]-----------------------------
#
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink" {catrow.forumrow.TARGET}>
|
REPLACE WITH
| Code:
|
#
#----------[ FIND ]-------------------------------------
#
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">
#
#----------[ IN-LINE FIND ]-------------------------------------
#
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">
#
#----------[ IN-LINE REPLACE WITH ]-----------------------------
#
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink" {catrow.forumrow.TARGET}>
|
Save, upload, and try again using EM...
Restoring EM Backups
If a MOD that you installed with EM hosed your board or you decide that you just don't want it, simply go into EM History in your ACP MOD Center and click on the Details button next to the MOD entry..
On the bottom of the next page, select Restore Backups and press the Go button. Make sure you DON'T select the Remove Record option or you will be forced to manually rolll back the EM backups that were created for you. I will have to walk you through that if need be...
Next you will see a page to confirm eht operation. You would choose Yes:
MODs can only be uninstalled in reverse order that they were installed: FILO (First In, Last Out). So if you installed a MOD, then several others, then decided to remove the first one, you would have to Restore the backups of the other MODs before you could Restore the backups on the first MOD...
Restoring EM Backups (Manual Instructions)
If you are unable to get into the ACP, you will need to use these manual instructions to Restore the EM Backups...
Download the backups folder that EM created for you in the MOD sub-folder found in admin/mods. Strip the .txt extension from each file in every folder in the backups folder. So the resulting file extensions will be php, tpl, css, and cfg. Upload the files back to their proper locations on your board; i.e.
- copy backups/admin/*.* to phpBB/admin/*.*
- copy backups/includes/*.* to phpBB/includes/*.*
- copy backups/language/lang_english/*.* to phpBB/language/lang_english/*.*
- copy backups/templates/subSilver/*.* to phpBB/templates/subSilver/*.*
- copy backups/*.* to phpBB/*.*
Of course if you have alternate templates and language folders, you will need to copy the files for them as well. I'm referring to phpBB as your forum's root folder in the above copy commands. If your root folder has any other name, just substitute phpBB with the name of your forum's root folder name...
 |
|
|
 |
 |
| Back to Top |
|
|
 | Re: [Solved] External Forum Redirect MOD |  |
Posted: 06/04/2007 3:56 AM |
|
|
|
|
|
| Hawk |
| Posts |
193 |
| Word Cnt. |
9,285 |
| BDay |
Jun 8 |
| Sign |
Gemini |
| Sex |
 |
|
|
|
Joined: Apr 25, 2007
Local time: 11:20 AM
Location: Esperance, Australia
|

|
|
|
|
 |
Excellent It works thanks again Nightrider  |
|
|
 |
 |
| Back to Top |
|
|
 | Information |  |
|